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Alternative Text (alt text)
Best Practices Guide

This best practice guide is intended as a general overview for PSEC staff
who are creating digital documents containing images such as reports,
digital promotions, emails, social media, or adding images to a website,

and is not intended as an in-depth resource for web developers. Additional
resources are available for more detailed information.
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What is alt text?

Alt text is a text description of an image that’s shown to people who are using assistive
technology or when an image doesn’t load properly on a webpage. Among others, alt text
helps:

e people with low vision or who are Blind
e people who have turned off images to save data

e searchengines

People with low vision or who are Blind may use assistive technology, such as screen
readers, to navigate the web. A screen reader transforms visual information to speech or
braille. To do this accurately, your website or document images need to have alt text.

Alt text is so important that it is the first success criterion of the Web Content
Accessibility Guideline (WCAG). The Accessibility for Ontarians with Disabilities Act
(AODA) requires that websites and digital content follow the guidelines outlined in the
WCAG.

All non-text content that is presented to the user has a text alternative that serves
the equivalent purpose.
— WCAG guideline 1.1.1

How do | add alt text?

ON A WEBSITE
In html, alt text is an attribute in an image element:
<img src="dog.png” alt="Dog playing in meadow.” />

Most content management systems (CMS), like Wordpress, let you create the alt text
when you upload an image:

Add Media * x

chihuahua-524924_1280

1 selected Insert into post
Clea


https://www.w3.org/WAI/WCAG20/quickref/#qr-text-equiv-all

IN ADOCUMENT

In most Microsoft programs, alt text can be added by right-clicking an image and
selecting “View Alt Text” from the drop-down menu.

IN ADOBE INDESIGN

In Adobe InDesign, alt text can be added by right-clicking an image and selecting Object
Export Options, and then selecting Alt Text. For the Alt Text Source, select Custom, then
type your alt text in the box available.

Cut Ctrl+X Object Export Options
Copy Ctrl+C
Paste CtrlsV e Tagged PDF | EPUB and HTML
Paste Into Ctrl+Alt+V
Paste in Place Ctrl+Alt+Shift+V ARIESEE Qo
Search Adobe Stock... e ¥ o
From Structure
Zoom a From XMP:Title
Transform > From XMP:Description
Transform Again > From XMP:Headline
Arrange > From Other XMP
Select % From XMP:Alt Text (Accessibility)
Lock Ctrl+L From XMP:Extended Description (Accessibility)
Hide Ctrl+3
Stroke Weight >
Fitting >
Effects >
Captions >
Extract from Image >
Find Similar Images
Hyperlinks >
Interactive >
Generate QR Code...
I Object Export Options... I
Tag Frame >
Autotag
Display Performance >
InCopy >
Graphics >
IN ADOBE ACROBAT

You can use the Accessibility Checker in Adobe Acrobat to identify missing alt text, then
right click the flagged issue and select “fix” which will open a window where you can input
your alt text.

Accessibility Checker X
> Document (3 issues)
Ga N Page Content (1 issue)
@ > Forms
v Alternate Text (1 issue)
a >0 [ﬁgursallerm(ehxt- F:
= Nested altemnate text - Passe¢ If'x_l
B ‘ Skip Rule
Associated with content - Pa|
% _ Explain
Hides annotation - Passed
E Other elements altematetext ~ <1eck Again
Show Report
S Tables
Options
> Lists

> Headings



How to write alt text

Follow these simple steps to write better alt text.

Begin by simply describing the image with as few words as possible. For example:
“A group of students playing soccer.”

“A happy baby in a swing.”

“A dog fetching a ball in a park.”

Things that do not belong in alt text are:

e Caption information, including the name of the photographer, image source, names
of people, or any information that is not visible in the image.

e Keywords for search engine optimization. While alt text can help with SEO, that’s not
what it is for, and filling it with irrelevant words is confusing to your users.

= CONSIDER THE CONTEXT
Keep it relevant
How you describe an image depends on its context. This the “why” of the image, and

how it’s relevant to the page content.

For example:

If the image above was featured in an article about construction equipment, the alt text
might be:

A red and yellow front-loader moving dirt outside a building.

If the image were on a website about the U of T Landmark Project construction of
Alumni Plaza, the alt text should be relevant to that project:

South view of Convocation Hall and the new Alumni Plaza, during construction.

If the image were on a page about U of T accessible infrastructure at King’s College
Circle, the alt text should be relevant to that topic:

Visual impairment markers being installed where paths intersect King’s College
Circle.

Remember to write alt text that is as meaningful as possible for the user in the context
they’rein.



SHORTER IS BETTER

Keep it concise
Try to convey the necessary information in a short, concise and relevant way, no longer
than 120 characters.

Sighted users can see more details in the sample image at a glance, such as the shape
of the building, the number of ionic columns, the colour of the door and the weather.
However, those details would take much longer than ‘a glance’ to be read by a screen
reader, and if they’re not relevant, they can become distracting verbal clutter.

COMPLEX IMAGES

Use text equivalents
But what if your image has text on it or conveys complex information like a chart,
infographic, or invitation?

In this case, the best practice is to provide a text equivalent by repeating all the
information in text near the image, and keep the alt text concise. This accessible
infographic from WebAIM, is a great example.

If the image-based text cannot be repeated in a text equivalent on the page near the
image (in the case of a web banner for advertising or promotion) the alt text should
contain the same words as the image.

IMAGES AS LINKS

Describe the destination
If the image links to another page, describe the destination, not the image.
For example, the U of T logo on utoronto.ca has the alt text “Home” not “U of T logo.”

AVOID REPETITION

Don’t use the word ‘image’

The screen reader already states “image” or “graphic” before reading your alt text in
a document. So if you write “photo of” or “image of” in your alt text the user may hear
“Graphic. Image of.”

Ifit’s a special type of image, like an illustration, that can be noted:
Dog jumping through a hoop. lllustration.

USE PROPER GRAMMAR
End with a period.

The more natural your alt text is, the more natural it will sound. Use proper grammar
and end with a period. Ending with a period allows the screen reader to pause after the
last word in the alt text, which creates a more pleasant experience for the user.

DON’'T USE THE TITLE-ATTRIBUTE

If your interface has a field for adding a title to your image close to where you add alt
text, skip it. The title attribute doesn’t work well, and you just don’t need it.


https://webaim.org/resources/designers/#infographic
https://webaim.org/resources/designers/#infographic

When NOT to use alt text

It's true! Images don’t always require alt text. Sometimes image alt text isn’t useful, and
can be redundant or distracting for a user.

DECORATIVE IMAGES

When an image doesn’t provide meaning to a user, it is considered decorative.
For example:

e \/isual styling such as borders, spacers, and corners;

e |cons orimages above or beside link text to make the link more appealing or
increase clickable areas. Find more info on icons with text labels and images with
links below.

e |mages that are identified or described by surrounding text, such as captioned
images, or complex images with text equivalents.

Alt text for these types of images would add audible clutter to screen reader output or
could be simply distracting from the page content.

ICONS WITH TEXT LABELS

You should always have text labels next to icons. Assuming you do, n
the icon should not have an alt text, because the screenreader will read Facebook
both, which would be the same. E.g. “Facebook Facebook.”

IMAGES WITH LINKS

Animage is often used to draw attention to a linked

headline, but the image does not add contextual value to
the content. Best practice is to leave the alt text blank on
this type of generic image (or on a web page use alt="").

This type of image is often linked to the same location as
the link text found directly below it. While it is not the best
practice to repeat links, it is a common practice in this

scenario. If you must make the image a link, then the alt March 27, 2023
text should describe the link destination, not the image.
Eg. News story on U of T World University Ranking. U of T scores top marks

in QS World University

Rankings by Subject
CAPTIONS VS ALT TEXT

A caption is used to provide information ABOUT an image, such as the date, location,
photographer, subject names etc., which are not visible in the image. This information
should not be in the alt text.

You may choose to describe the image in the caption as well, in which case the image
does not need alt text. If you use both alt text and a caption be careful to avoid repetition.


https://axesslab.com/icons-ruining-interfaces/

How to treat decorative images
ON A WEBSITE OR NEWSLETTER

Use an alt tag with a space in it, known as an empty alt tag (alt="") so the image can be
ignored by assistive technologies, such as screen readers. Leaving out the alt attribute is
not an option because when it is not provided, some screen readers will announce the file
name of the image instead.

Adding the space in the empty alt tag may require you to access the html code of your
webpage or newsletter. Do not type ““ into the alt text box as assistive technologies may
read “quote quote.”

IN PDF

Decorative images can be tagged as an Artifact to be ignored by assistive technologies
by using the accessibility assistant in Acrobat reader, or in InDesign by right clicking an
image and using the Object Export Options.

IN OTHER DOCUMENTS AND EMAILS

You can leave the alt text blank, or provide a short description of the purpose of the
image. For example, if you are including an image of an invitation or event promotion in
an email, the full text of the invitation or event details should also be in the message. The
image is now decorative and may be described as “Promotional banner for X event.”

Note: if the image is a link to register for the event or RSVP, be sure to describe the
destination of the link in the alt text instead. eg. alt="RSVP form for X event.”

Additional resources for alt text:

e Writing alt text based on the purpose of the image (W3C)

¢ Review a decision tree to help you decide when to use alt text (W3C)

e How to write good alt text (Harvard University)

¢ Accessibility: Image alt text best practices (Siteimprove)

e Making Images Accessible (a collection of resources from the DIAGRAM Center for
describing complex images)

e Understanding SC 1.1.1—Non-text Content (WAI)

e Example of an accessible infographic (WebAIM)



https://www.w3.org/WAI/tutorials/images
https://www.w3.org/WAI/tutorials/images/decision-tree/
https://accessibility.huit.harvard.edu/describe-content-images
https://support.siteimprove.com/hc/en-gb/articles/115000013031-Accessibility-Image-Alt-text-best-practices
http://diagramcenter.org/making-images-accessible.html
http://www.w3.org/TR/UNDERSTANDING-WCAG20/text-equiv-all.html
https://webaim.org/resources/designers/#infographic

Summary

FOLLOW THESE SIMPLE STEPS TO WRITE BETTER ALT TEXT.

1. Consider the context.
Describe what is relevant in the image, as it relates to the content of the page it
appears on.

2. Keep it short.
Try to convey the necessary information in a concise and relevant way, no longer than
120 characters.

3. Use text equivalents for complex images.
Have a lot of information in your image? Repeat complex information in text near the
image, not in the alt text. Can’t repeat the information in text? Then include all the
same words in your alt text.

4. Describe the destination
If your image is being used as a link, use the alt text to indicate where the link goes,
and not what the image is.

5. Use proper grammar
Include a period and proper grammar to make your alt text sound more human.

6. Prevent repetition
Consider the surrounding text. Don’t repeat the title, caption, or text that’s in the
surrounding copy, and don’t use the phrases “image of,” “photo of,” or “graphic of.”

7. Use captions instead
Use a caption, instead of alt text, to relay information that is not in the image or
surrounding text, such as the location, subject names, or photographer.

8. Leave out decorative elements
Leave alt text blank if the image is just for attention or aesthetics.



=

How to write

CONSIDER THE CONTEXT

Describe what is relevant in the image, as it relates
to the content of the page it appears on.

KEEP IT SHORT

Convey the necessary information in a concise and
relevant way, no longer than 120 characters.

USE TEXT FOR COMPLEX IMAGES

If you have a lot of or complex information in an image,
repeat it in text near the image, not in alt text. If that is
not possible, include all the same words in the alt text.

DESCRIBE THE DESTINATION

If your image is being used as a link, use the alt text
to indicate where the link goes, and not what the
image is.

USE PROPER GRAMMAR

Include a period and proper grammar to make your
alt text sound more human.

PREVENT REPETITION

Consider the surrounding text. Don't repeat the title,
caption, or text that's in the surrounding copy, and don't
use the phrases "image of,” "photo of,” or “graphic of.”

USE CAPTIONS INSTEAD

Use a caption, instead of alt text, to relay information
that is not in the image or surrounding text, such as the
location, subject names, or photographer.

LEAVE OUT DECORATIVE ELEMENTS

Leave alt text blank if the image is just for attention
or aesthetics.
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